Ryzen 7 Hackintosh

Discussion in 'Build Logs' started by WanderingMendicant, Aug 1, 2017.

  1. WanderingMendicant

    WanderingMendicant Chassis Packer
    Thread Starter

    It's definitely possible to get the m.2 SSD working on a Hackintosh. Head over to tonyxmac86 and there are a few long threads. But it looked like a huge PITA compared to SATA or PCIe SSDs and I wanted to keep my operating systems on separate hard drives anyway... so I didn't bother.

    I've overclocked up to 3.8 GHz/1.4V on both operating systems and it's quite stable. I'm sure it can go higher but I don't feel the need to stress the system, especially since it's a small case. Here's the geekbench result:

    http://browser.geekbench.com/v4/cpu/3648769

    Not bad for $1,300. The current top-of-line Mac Pro has a multi core score of 25,061 which I could easily surpass if I OCed to 4.0 GHz... and the trash can costs $5,199. It's too bad, I have loved my MacBookPros and the iMac I used from about 2011-2015... but the products are way too overpriced these days. It will be interesting to see if the next rendition of the Mac Pro is modular/customizable or another ripoff.
     
    Biowarejak and Acalanata like this.
  2. neilhart

    neilhart SFF Lingo Aficionado

    Very nice write up on your hackintosh installation. I went the InsanleyMac route and have nearly the same thing on my Ryzen 7 1700X hack.

    On my system the GPU performance is low as compared to on my Intel systems. Have you compared your GPU performance in Windows and macOS? Cinebench_R15 is the benchmark that gives both GPU and CPU data on both Windows and OS X. I don't run Windows so I can not get the data myself without going out and acquiring a license for Win10.

    Neil
     
  3. WanderingMendicant

    WanderingMendicant Chassis Packer
    Thread Starter

    I ran Cinebench on Windows 10 and OS X. I got almost the exact same value (1669 vs 1668 or something) for the CPU, but also got a low GPU value running OS X. It was around 100 fps on Windows 10 and 50 fps on OS X. No idea if that is an issue with actual performance or Cinebench or Hackintosh drivers, etc. I will do all my gaming on Windows and audio production on OS X so it doesn't really affect me, but definitely a bit odd.
     
    owliwar and Acalanata like this.
  4. neilhart

    neilhart SFF Lingo Aficionado

    #24 neilhart, Aug 14, 2017
    Last edited: Aug 14, 2017
    Thank you for the Cinebench data. I found an old copy of Window 8 and installed it so that I could run the same thing on my system and found that in Windows I had 93 FPS and on maxOS I had 42 FPS (this on 10.12.6 and GTX 960, MB Gigabyte AB350N).

    Also please share your observation of the "About this Mac": the processor is not identified on my system and on your screen capture it is "3.4 GHz AMD Ryzen 1700X" . Did you make edits to get this displayed?

    And when I run GeekBench 3 or 4, the app displays "1 Processor 16 Cores" . And in Cinebench I see "Cores x GHz 16 Cores, 16 Threads @ 3.39 GHz" . Do you see this or is the info correct on your system?

    Neil

    Edit: I think my problem is my macOS installation. The Core and Thread information is presented correctly in Windows Cinebench and not so in macOS Cinebench.

    Neil
     
    owliwar and Biowarejak like this.
  5. WanderingMendicant

    WanderingMendicant Chassis Packer
    Thread Starter

    Yeah, I edited the 'About this Mac' info and changed the picture to match my case. To change system logo, go to /Applications/Utilities/System Information -> Show Package Contents -> Contents/Resources and then replace SystemLogo.tiff (can replace it with SystemLogo.jpg/png, as long as you delete the tiff).

    To edit computer model, go to Users/XYZ/Library/Preferences/com.apple.SystemProfiler.plist. You probably have to enable showing hidden files/folders and XYZ is your login name. Edit the description that follows 'CPU Names' to whatever you'd like. I couldn't think of a very creative name for my little guy :p

    To edit the CPU description, go to System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/English.lproj/AppleSystemInfo.strings and then edit the string after 'UnknownCPUKind'.

    Cinebench recognized my CPU on both operating systems... didn't try GeekBench on OS X yet because you need to be online and I don't have ethernet at the apartment, just wireless.
     
    Biowarejak likes this.
  6. phaelax

    phaelax Caliper Novice

    Support for a hackintosh must've come a long way since I last tried it with a P4. Never thought I'd see it run on an AMD though.
     
    Biowarejak likes this.
  7. neilhart

    neilhart SFF Lingo Aficionado

    Thank you for the info. I am seeing the wrong Core info in CineBench on maxOS. Again, could you check yours?
    [​IMG]

    Neil
     
    Biowarejak likes this.
  8. WanderingMendicant

    WanderingMendicant Chassis Packer
    Thread Starter

    Hadn't noticed it the first time around, but same as you on OS X... 16 cores, 16 threads. It does change the 3.39 when I overclock, so I assume it is detecting the important stuff.
     
    Biowarejak likes this.
  9. JasonY

    JasonY What's an ITX?

    Have the exact same hardware configuration as you listed here, but the install is hanging at the root device line and then i get the circle with the line through it.

    The only thing I have done differently is I made the usb boot drive using my mac - when i get to the first boot screen I've tried adding the -v npci=0x2000 nv_disable=1 to the stuff that is already there, and also tried clearing the existiing boot flags out and just putting in -v npci=0x2000 nv_disable=1.

    Not sure why this keeps crashing, any thoughts would be totally appreciated.

    -J
     
  10. neilhart

    neilhart SFF Lingo Aficionado

    #30 neilhart, Oct 29, 2017
    Last edited: Oct 29, 2017
    Jason I have a clone macOS 10.13 build 17A405 running with the Bronya Kernel and system.kext found on insanelymac.com at this link: http://www.insanelymac.com/forum/topic/325514-amd-high-sierra-kernel-release-and-testing/

    I am using Clover_v2.4k_r4220 and I use boot arguments "npci=0x3000 busratio=34" in my config.plist and run as iMac 14.2.

    In my opinion, less is better so I do the minimum of hacks to the Apple OS.

    There are some key processes found in the AMD section at: http://www.insanelymac.com/forum/topic/324392-ryzen-clover-installation-guide-macos-sierra/page-1

    I find this process useful. See this at the link above. "On first boot hit the space bar at clover screen (after setting bus ratio above) and select: Verbose, Single User, KeepSymbols, Don't Reboot on Panic, and Debug Kexts options, scroll to bottom hit return and the enter to boot.

    It should stop at Root: type in "mount -uw" hit enter, type "fsck -fy" hit enter and wait then type "exit". All of these are done without the " " marks. It will either boot into Sierra or stop very close to booting. reboot if necessary and just hit enter.
    If you get booted run Kext wizard and then try a reboot. "

    And as needed, to re-build the prelinked kernel, use the terminal.app with the following;

    sudo -s

    rm -f /Volumes/New1/System/Library/PrelinkedKernels/prelinkedkernel

    touch /Volumes/New1/System/Library/Extensions

    kextcache -u /Volumes/New1

    exit

    Note you use your partition name instead of "New1" .

    Good luck,
    Neil
     
    Soul_Est likes this.
  11. zzmadd

    zzmadd Caliper Novice

    #31 zzmadd, Jan 15, 2018
    Last edited: Jan 16, 2018
    WanderingMendicant
    what is the exact mITX motherboard that you're using?
    I use the ASRock Fatal1ty AB350 Gaming-ITX/ac and I'm having USB issues both in USB2 and 3 with my Apple USB keyboard.
    Issues "per se" with USB and related to sleep / wake

    Do you have a flawless system?
    Thanks for your help.
    Luca
     
  12. TimurLivanov

    TimurLivanov Case Bender

    Did you manage to solve the problem with FPS? I have the same situation in games and on the benchmark FPS is low ((
     
  13. TimurLivanov

    TimurLivanov Case Bender

    Did you manage to solve the problem with FPS? I have the same situation in games and on the benchmark FPS is low ((