Power Supply Can't tell if Dell brick of HDPLEX got fried

reifnotreef

Average Stuffer
Original poster
Feb 10, 2019
65
20
I was doing some stress testing yesterday on my current build. PC crashed during a run of Superposition, this had happened before. I figured I had drawn too much power for the Dell 300w brick. I unplugged the power and plugged everything back in like I had done before but this time it wouldn't turn on.

The green light on the Dell brick comes on when I plug it in to the wall, no light comes on on the HDPLEX 400w dc-atx though. I am waiting on my 400w ac-dc that will replace the 300w brick.

I have hooked up my mobo to a 150w psu I have from my InWin Chopin and everything boots just fine(using onboard video). I might be able to get a psu from work to tide me over until my hdplex ac-dc comes in.

To determine which piece failed(Dell brick vs hdplex) what should I do?
 

Thehack

Spatial Philosopher
Creator
Bronze Supporter
Mar 6, 2016
2,725
3,478
J-hackcompany.com
If you have a multimeter, while the power supply is not plugged into the computer:

1. Plugged into wall power, check the output of the ac-dc adapter. If it reads approx 19V you have 19V output. And likely the adapter is working fine.

2. With the barrel power connector plugged in, check that there is 19v on the connector side of the power entry pcb. The part that you plug into the hdplex 400 itself. If 19V is not there, it is the power entry pcb.


3. With everything hooked up except for plugging into the pc components, Check the 5VSB pin on the hdplex 400. It is one of the 24pin atx pins. Reference COM pin to get a reading. If this is not there, your 5vsb and VRM circuit is dead. Hdplex is the fault.

4. If 5vsb is there, short the PS_on pin to COM pin. This will turn the hdplex 400 on. Check the 12V output on one of the pcie power connector. If this does not read 12V, your primary rail is dead and the hdplex is the fault.

If the above sounds difficult, RMA one of the two.
 
  • Like
Reactions: Arboreal

reifnotreef

Average Stuffer
Original poster
Feb 10, 2019
65
20
Just wanted to post a quick follow up to my original.
I emailed Larry at HDPLEX to ask a couple questions about the 400w dc-atx unit. He asked me a couple questions about my setup and then emailed me a shipping label. I am sent him my current 400w dc-atx unit(v1.4) and he said he will ship me a new (v1.6) 400w dc-atx unit with my pre-ordered 400w ac-dc.

I showed my girlfriend our email conversation and even she's impressed!
Larry is a LEGEND.
 
  • Like
Reactions: Arboreal and Kmpkt